Loader Reinstalled FEL - now it won't lift up

   / Reinstalled FEL - now it won't lift up #1  

SouthernSky

Gold Member
Joined
Jun 10, 2005
Messages
343
Location
Deville, LA
Tractor
2013 Kubota L3200DT
My L2650 tractor was just split and a PTO gear changed. To save some expense of the ag tech doing it, I removed my front end loader and left it at the house. I have it physically back on but it won't go up, though I can stop the arms from lowering and the bucket from turning face down.

I know the FEL lost a bunch of hydraulic fluid on the ground while it was sitting up as I really didn't plug the one thinner hose like I should have. I'm assuming air got into the lines?

Is there a procedure to bleed or whatever to get the FEL to work again? I've been through the WSM and the owner's manual but can't figure this one out. I thought maybe I had the IN/OUT lines reversed but switching them didn't help.

The site glass shows the hydraulic fluid now at the correct level (it was low) but no change to FEL operation.

Any suggestions are truly appreciated!
 
   / Reinstalled FEL - now it won't lift up #2  
The system is self-bleeding, the only procedure is to operate the controls several time in all directions to purge the air. Does the engine labor at all?
 
   / Reinstalled FEL - now it won't lift up
  • Thread Starter
#3  
I just checked, moving all positions for about 10 minutes -- no go. The engine does not seem to be laboring at all.

If I remove the OUT hose on the back of the hand lever/joystick and press the center ball, fluid does come out. I'm not seeing that when I disconnect the IN hose.
 
   / Reinstalled FEL - now it won't lift up #4  
Lines connected right?
 
   / Reinstalled FEL - now it won't lift up #5  
Does that tractor have color coded lines like the B series.
 
   / Reinstalled FEL - now it won't lift up
  • Thread Starter
#6  
The lines were never disconnected except at the quick disconnects located down by the front block. I tried swapping them (since two are the same size) but it didn't make any difference.

No color coding. :(
 
   / Reinstalled FEL - now it won't lift up #7  
gotta be a connection problem. Can you depress each of the nipples before connecting? Are the connectors really seated?
 
   / Reinstalled FEL - now it won't lift up #8  
I agree with Island Tractor, make sure every connectors are really seated. I had the same problem with my bx2350 once. The connector seemed to be done right, nothing popped off when I tugged on them, but the loader wouldn't raise. I in desperation, disconnected each line & discovered that one wasn't fully seated. reconnected everythig & it worked like a champ. Now I'm very deliberate about reconnecting the hoses.
 
   / Reinstalled FEL - now it won't lift up #9  
Same thing happened to me the first time I put my backhoe back on. FEL wouldnt go down tho not up. Was working fine earlier that day tried bleeding air/making messes figured the new tractor now 2000 miles and a ferry ride and then a 130 mile boat ride from the dealer was tu.(this was b4 internet out here and tbn) :laughing: so out of desperation I checked the connections on the bh and sure enough one of the quick connects even though it looked good wasn't connected all the way.:laughing::laughing::thumbsup:
good luck
Rick
 
   / Reinstalled FEL - now it won't lift up
  • Thread Starter
#10  
Of all the stupid things ...

It turns out there is a screw on the front hydraulic block that rotates about 90 degrees between the Open and Closed position. Apparently my ag tech actually read my WSM and turned it to the Closed position which still allows the three-point hitch to work, just not the loader.

I'm back in business. Thanks all!
 
 
Top