L3200 electrical - Only tach and temp gauges don’t work.

   / L3200 electrical - Only tach and temp gauges don’t work. #1  

SouthernSky

Gold Member
Joined
Jun 10, 2005
Messages
343
Location
Deville, LA
Tractor
2013 Kubota L3200DT
Fuel gauge works, but tach and temp do not. Checked the 10A panel fuse and it looks good. All other electrical on the tractor works fine. I just need to figure out why these two stopped working yesterday.

Any thoughts? Thanks!
 
   / L3200 electrical - Only tach and temp gauges don’t work. #2  
Did the tractor or gauge cluster get wet?

Have you checked the wiring for a rodent infestation?
 
   / L3200 electrical - Only tach and temp gauges don’t work.
  • Thread Starter
#3  
I did wash the tractor a few days ago but it surely would have dried by now. I will check the wiring as I do have a stray cat that seems to find home in different parts if my tractor.
 
   / L3200 electrical - Only tach and temp gauges don’t work.
  • Thread Starter
#4  
Nope. No sign of water visible and the fuse has continuity. It is the Panel 10A fuse that controls these two, right? Wouldn’t the fuel gauge also stop working though?
 
   / L3200 electrical - Only tach and temp gauges don’t work. #5  
It does.

However, now that you've looked at the wiring, only thing it can be is a the gauge cluster.

Doubt that two sensors would've went out.
 
   / L3200 electrical - Only tach and temp gauges don’t work.
  • Thread Starter
#6  
It does.

However, now that you've looked at the wiring, only thing it can be is a the gauge cluster.

Doubt that two sensors would've went out.

Hmm.. odd they both went out together. Could it be a loose connector not making good connection? I can’t find a clear electrical diagram. I’m trying to figure out if the connections for the two are separate in any way from the fuel gauge.
 
   / L3200 electrical - Only tach and temp gauges don’t work.
  • Thread Starter
#7  
Okay, now the coolant temp gauge is working, but the PTO/tach and hour meter aren’t working.
 
   / L3200 electrical - Only tach and temp gauges don’t work. #8  
To further complicate this mystery,I think your L3200 has a mechanical cable-driven tach/hourmeter.

Good Luck!
 
   / L3200 electrical - Only tach and temp gauges don’t work. #9  
Hmm.. odd they both went out together. Could it be a loose connector not making good connection? I can’t find a clear electrical diagram. I’m trying to figure out if the connections for the two are separate in any way from the fuel gauge.

If you need it, I have a PDF of the Electrical Diagram.
 
 
Top