Mahindra 1526HST glow plug issue

   / Mahindra 1526HST glow plug issue #1  

Kaintuck1977

New member
Joined
Apr 2, 2021
Messages
3
Tractor
Mahindra 1526HST
Hello and thanks for any help....I'm at a complete loss. I have a 1526HST that would not start, and I tracked it down to not getting 12 volts to the glow plugs. I have the service manual with the wiring schematic, and was able to trace to where I have 12 volts on the "a" side of the glow plug controller. I also have the 12 volts control voltage to the controller when I turn the key to power up the glow plugs, and the glow plug light comes on the dash. I get 12 volts to the "B" wire going to the plugs, but the instant I touch this wire to the plug buss bar, it goes away. I thought, "Maybe it's the controller dropping out" so I bought a new one at 140 bucks, though my local dealer advised me to just add a push button switch in its place and forget it. I wish I had now.

Put the new controller in today, and same problem. I have ohmed out all three glow plugs individually, I get about .6 ohms on each. I have a good ground connection with the block....(.2 ohms from negative battery to block threads for glow plugs). If I jump 12 volts directly to the plugs, they light up and the tractor starts. Thought maybe the battery was getting weak (5 years old) and causing me to lose control voltage to the glow plug controller, so i bought a new battery today. Same issue. I have run a new battery cable, new battery terminals, cleaned off every chassis ground I can find (I do get a good ground on the appropriate pin on the controller, so I don't think that's the issue), checked every fuse I know of, cleaned the threads on the plugs, this makes absolutely no sense!? What would cause my voltage to be there with the wire hangin in air, but disappear when I touch it to the plugs?? Tried to see if the plug was lighting with a plug out of the block, body shorted to ground, my 12 volts disappears that way too, so I know they aren't coming on.

Sorry if it's long...I just wanted to give as much info as I could. Thanks a lot for any help.
 
   / Mahindra 1526HST glow plug issue #2  
Have you checked to see if there's a relay in the glow controller circuit?
If there is try checking it and the wiring from the glow controller, fuse box.
 
Last edited:
   / Mahindra 1526HST glow plug issue
  • Thread Starter
#3  
I did not see one, but there is a relay for the starter and one labeled "Load". Is that it? I did switch that relay with one for the lights, and that didn't fix anything, as well as pulled the starter relay to verify that it wouldn't crank. I have checked the fuses I think would feed this circuit...there's a 50 amp that's good as well as the 10 that, according to the schematic, would be the two in play for this circuit.
 
   / Mahindra 1526HST glow plug issue #4  
The relay labeled load is the one I'm talking about, do both relays have same part number. Have you tried tracing the circuit with an Ohm meter from the controller. Just sounds like maybe a broken wire or bad connector which would be my first guess. Does both lamp and load relay even pick?
On my diagram pin 2 on the controller is labeled as battery and 5 is glow plugs, does yours also?
Also on my controller connector I show a black wire which is labeled as ground, something to also check.
 
Last edited:
   / Mahindra 1526HST glow plug issue
  • Thread Starter
#5  
Yes sir that's correct. Two is what I was calling the "A" side and 5 the "B" side....this schematic is so small in my manual I need a flashlight and magnifying glass to see it lol. I also had 12 volts to terminals 1 and 4 on the controller when I turned the key as I should, and terminal 5 was ground as it should be. Starter, Load, and Rear Lamp L and R are all the same relays, and I tried swapping out one of the rear lights for the Load yesterday to no avail.

Update, though, I just tried to start the tractor and it fired right up. Thinking it might be just cause it's warmer out today, I checked voltage at the glow plugs and had 10.5, so why I didn't yesterday and I do today is a mystery to me. I repeated this two more times, and had voltage. The one thing I did, after jumping the plugs to get it started yesterday, was to hose everything down real well. My father has been using it to build rock baskets, so everything was pretty dusty. Maybe I was getting a bad connection at the Load relay and I cleaned it. I will go back with contact cleaner and clean all those terminals real well, and I'm gunna go ahead and replace those relays in case they're intermittent, especially since it fixed itself, and could unfix itself in the future just as easily.

Thanks a lot for your help!
 
   / Mahindra 1526HST glow plug issue #6  
voltage drop test would find it pretty quick.... also on my 26 there is a black spade disconnect, this is melting on mine prolly from bad connections, make sure the connector is making good contact if you have this design
 
   / Mahindra 1526HST glow plug issue #7  
I had the same problem with my Max 24 not getting any voltage at the glow plug terminal unless I disconnected it the was getting 12V .. when I touched the glow plug terminal the voltage would disappear to ) volts.. after checking the control timer relay ...ign switch...fuses ... i started tracing the wires and found it at the glow plug terminal where the wire from the control relay supplied the voltage for the glow plugs... it did take a a while to figure out as I tested the relay and it was working properly then as it was removed I jumped the leads and was getting voltage to the glow plugs terminal but when u touched it to the glow plug... the voltage again disappeared. The wire right as it went into the glow plug terminal was not secure enough to handle the amperage load ... Hope that helps....
 
   / Mahindra 1526HST glow plug issue #8  
I had the same problem with my Max 24 not getting any voltage at the glow plug terminal unless I disconnected it the was getting 12V .. when I touched the glow plug terminal the voltage would disappear to ) volts.. after checking the control timer relay ...ign switch...fuses ... i started tracing the wires and found it at the glow plug terminal where the wire from the control relay supplied the voltage for the glow plugs... it did take a a while to figure out as I tested the relay and it was working properly then as it was removed I jumped the leads and was getting voltage to the glow plugs terminal but when u touched it to the glow plug... the voltage again disappeared. The wire right as it went into the glow plug terminal was not secure enough to handle the amperage load ... Hope that helps....
hmm you don't say... :)

 
   / Mahindra 1526HST glow plug issue #9  
I know this is an older post, but I have had a similar problem a couple of times with my 1526hst. Nothing tested right. I eventually bought a set of cheap Amazon glow plugs and installed them... fires right up. Put old glows (tested good) in again because I'm curious... no fire. After six months go by give or take... same problem... glows test good... electricals don't. Another cheap set of Amazon glows and fires right up and the electrical gremlin went away.
Still can't explain the issue, but for 60 bucks a year in glow plugs, don't really care to chase a gremlin.
 
 
Top